світч з двома і більше аплінками

Нові коментарі

Нова тема   Відповісти
Автор Повідомлення
marchelloUA 
Поважний учасник


З нами з: 13.04.11
Востаннє: 21.08.17
Повідомлень: 152

2017-04-28 20:17  
Привіт всім.
Дозрів до зміни світча. Наразі в мене D-Link DIR-320, в якому лише один аплінк. Тобто коли треба переключитися на іншого провайдера, це робиться руками. Зараз роздумую над моделлю світча, де би було два і більше аплінки, а також можливість підключити usb-модем (бажано теж більше одного).
Прохання поділитися досвідом.
Щиро вдячний.
lex 
Відео Гуртом - підтримка та поширення
Відео Гуртом - підтримка та поширення


З нами з: 25.12.07
Востаннє: 21.08.17
Повідомлень: 577

2017-04-29 20:30  
mikrotik 450g
marchelloUA 
Поважний учасник


З нами з: 13.04.11
Востаннє: 21.08.17
Повідомлень: 152

2017-04-29 21:16  
то в нього 4 порти для підключення компів і 1 аплінк же ж ?
ну судячи з фоток принаймні..
чи там кожен порт налаштовується програмно на потрібний функціонал?

Додано через 6 хвилин 48 секунд:

а, сорі... на цій фотці побачив схему нарешті, виходить там 4 аплінки і один для компа..

2 тисячі гривень справді варто за нього дати??
lex 
Відео Гуртом - підтримка та поширення
Відео Гуртом - підтримка та поширення


З нами з: 25.12.07
Востаннє: 21.08.17
Повідомлень: 577

2017-04-29 21:50  
на олх за 30 баків взяти...
в мене така штука агрегує три аплінки в один

Додано через 1 хвилину 12 секунд:

+ то не свіч то роутер л3 рівня.
теоретично можно на ньому і більше аплінків підняти

Додано через 1 хвилину 15 секунд:

http://asp24.com.ua/mikrotik-routerboard/mikrotik-routerboard-rb450g/
marchelloUA 
Поважний учасник


З нами з: 13.04.11
Востаннє: 21.08.17
Повідомлень: 152

2017-04-30 00:41  
Так, вже знайшов юзаний і написав до продавця. Сподіваюся, з понеділка буду вже мати. Дякую!

До речі, чи якось можливо також агрегувати трафік з 3G модема?
lex 
Відео Гуртом - підтримка та поширення
Відео Гуртом - підтримка та поширення


З нами з: 25.12.07
Востаннє: 21.08.17
Повідомлень: 577

2017-05-01 12:50  
tam zdajetsa je usb port. ale treba dostavyty paket z drajveramy. ma mikrotik.com to vse je
marchelloUA 
Поважний учасник


З нами з: 13.04.11
Востаннє: 21.08.17
Повідомлень: 152

2017-05-01 13:23  
Придивився на фотках по лінку вище - нема, або ж добре ховається Wink (1)
Схиляюся до того, щоб взяти додатково також якийсь роутер типу zyxel keenetic для агрегування також трафіку з 3g usb модему...
marchelloUA 
Поважний учасник


З нами з: 13.04.11
Востаннє: 21.08.17
Повідомлень: 152

2017-05-19 02:04  
lex
Хотів подякувати, друже, за пораду.
Хоч я неуважно прочитав і купив на olx модель Mikrotik RB450, а не Mikrotik RB450G, та все одно дуже задоволений.

Ну ок... визнаю, мені не по зубах було налаштування мікротіка ((((( і я знайшов на тому ж olx місцевого майстра.

Чемно переключається з основного на резервний канал. І назад. Поки що в бойовому режимі не довелося побачити, лише імітував пропадання зв'язку, витягуючи шнур з порта.

Значить в мене на eth1 по ppoe конектиться до провайдера, котрий заходить в хату по езернету.
Там єдиний мінус - що при відновленні з'єднання ppoe не відразу ж піднімається, не знаю чи це підлягає покращенню.
Мабуть це особливість технології ppoe.

На eth2 в мене Zyxel Keenetic 4G. На тому ж olx знайшов. Брав щоб налаштувати usb модем(и).
Досить просто піднявся kyivstar, правда в мене від нього в наявності лише 2G модем ZTE і швидкість відповідно низька.
Втикнув Novatel Rev.A від intertelecom - взагалі нема нарікань, ну ще би знайти Rev.B щоб було ще краще.
Біда-печаль, що мій ноунейм модем від "ватафону" (Vodafone) при нагріванні після деякого часу роботи пропадає.
Бо на ватафоні найсмачніший тариф, якраз для мене: 500 мб на день за 5 грн на місяць (і найкрутіша швидкість серед випробуваних - в зоні дії 3g, щоправда, котра поки що лише в великих містах і в деяких ще точках).
Тобто якраз для ситуацій, коли основний інтернет пропадає ненадовго і рідко.
Мабуть що це вирішується шляхом пошуку розлоченого usb модему, ну цим пізніше займуся.
Лайф usb не пробував, хоча чув що там доволі хороші показники, може колись.
Укртелеком usb не пробував і мабуть не збираюся.

А, ну ще веб-інтерфейс Zyxel Keenetic говорить, що там можна підключати декілька модемів одночасно і виставляти пріоритетність.
Ну не знаю, usb-порт там лише один, я пробував через різні usb-хаби і лампочки модемів весело миготять, от тільки в такому варіанті Zyxel їх взагалі не бачить.
Може ще спробую пізніше usb-хаб із зовнішнім живленням, може їм на декількох не вистачає тих міліампер, котрі видає Zyxel.

"Нормального" резервного провайдера не знайшов в себе.
Є один, в якого основний хліб це кабельне телебачення, на нього жаліються що інтернет з 90-х років.
Є ще "ОГО-го", який колись давно в мене був недовго і більше не хочеться.
Є ще якийсь радіо-інтернет, для якого треба купити обладнання для під'єднання.
А потім невідомо, що з ним робити, якщо не сподобається.
Так що пачка usb-модемів нормальний варіант на запас.

Ще не знаю як поступити з налаштуванням торентів. Бо качати/роздавати все ж треба лише через основний інтернет.
Але якщо вижре всі гроші на мобільному інтернеті, то не дуже велика втрата.

А... теоретично ще буду в перспективі зацікавлений в можливості налаштування "змішування" трафіку від різних провайдерів в один канал.
Але зараз режим переключання з основного на резервний канали повністю влаштовує.

Наступне питання буде - резервне живлення... Але про це згодом.
Krest0 
VIP


З нами з: 23.01.16
Востаннє: 22.08.17
Повідомлень: 568

2017-05-19 02:32  
marchelloUA написано:
marchelloUA

Поставте посилання під спойлер. Бо сторінка сильно розтягнулася.
marchelloUA 
Поважний учасник


З нами з: 13.04.11
Востаннє: 21.08.17
Повідомлень: 152

2017-05-19 02:38  
Krest0
є
lex 
Відео Гуртом - підтримка та поширення
Відео Гуртом - підтримка та поширення


З нами з: 25.12.07
Востаннє: 21.08.17
Повідомлень: 577

2017-05-20 10:37  
marchelloUA написано:
Чемно переключається з основного на резервний канал. І назад. Поки що в бойовому режимі не довелося побачити, лише імітував пропадання зв'язку, витягуючи шнур з порта.

можна зробити два аплінки одночасно поверх цього але треба щоб машинка з лінухом була і піднімати дві версії торентдемона
marchelloUA написано:

Там єдиний мінус - що при відновленні з'єднання ppoe не відразу ж піднімається, не знаю чи це підлягає покращенню.
Мабуть це особливість технології ppoe.

то до хвилини часу
marchelloUA написано:
Біда-печаль, що мій ноунейм модем від "ватафону" (Vodafone) при нагріванні після деякого часу роботи пропадає.

розбери пластикой корпус і постав на горячий чіп або маленький радіатор або дуйку якусь направ. літо починається то буде у всіх жопєнь з перегрівами
marchelloUA написано:
Є ще якийсь радіо-інтернет, для якого треба купити обладнання для під'єднання.

одладнання дороге по вечорах інет буде лагати бо часпік
marchelloUA написано:
Наступне питання буде - резервне живлення... Але про це згодом.


в мене є ідея але я її ще не реалізовував.
ідея в наступному
1. берем упс від апц
2. дородляєм електронну ділянку лише так, щоб упс працював лише на заряд
3. берем напряму з акума дц-степерами і виводим живлення напряму на мамку.

+ більша ефективність та робота від акума

також в продажі бачив вже щось подібне готове
220 на 24 або 220 на 12

або бачив в китаї відразу готові перехідники для материнських плат. 12в вхідний а перехідник вже сам розкидає що куди

в мене зараз стоїть упс. але я його буду переобляти
marchelloUA 
Поважний учасник


З нами з: 13.04.11
Востаннє: 21.08.17
Повідомлень: 152

2017-05-20 15:18  
Цитата:

два аплінки одночасно


ну коли буде два ethernet провайдери, тоді буде про що говорити в цьому напрямку

Цитата:

щоб машинка з лінухом була


в мене лише лінух на всіх компах, ось вчора довелося поставити на віртуалку вінду вперше за майже рік для короткої задачі

Цитата:

піднімати дві версії торентдемона


можна для загального розвитку, тільки в мене торенти далеко не пріоритетний напрямок діяльності.. ) я в цьому питанні зараз більше споживач - жінці кіно скачати, дітям мультики, собі рідко що

Цитата:

до хвилини часу


ppoe дійсно до хвилини часу, але мені це трохи критично, бо за цей час встигає порватися сесія vpn / ssh, ну але маємо що маємо

Цитата:

розбери пластикой корпус


пробував той модем колупати, викрутив малесенькі болтики, але далі без ламання пластмаси поки що не піддався, може ще віднесу назад в салон, бо наче ще по чеку можна здати, може мають людські моделі типу зте чи хуайвей

Цитата:

1. берем упс від апц
2. дородляєм електронну ділянку


так як в мене (1) руки не звідти і (2) бюджет дозволяє, то дивлюся щось таке:
http://elektro.in.ua/home-catalog/istochniki-besperebojnogo-pitanija/luxeon-ups-800s.html
там ще правда буде акум за таку ж ціну, а може і не один треба буде одночасно (вимикають, буває, на годину, а роботу робити треба). Це до компів, там менше 500 ват смислу нема, хіба що коли запищить щоб коректно все повиключати встигнути.

А в щиток, де мої світчі і всяке низьковольтне барахло, то може щось простіше пошукаю.
lex 
Відео Гуртом - підтримка та поширення
Відео Гуртом - підтримка та поширення


З нами з: 25.12.07
Востаннє: 21.08.17
Повідомлень: 577

2017-05-23 07:41  
взяти на олх апц за 10-15 баксів і купити йому новвий акум....

Додано через 5 хвилин 7 секунд:

ну для свічів можна на акум кинути таку штуку як дц-дц степпер....ака штука все вирішить

https://diylab.com.ua/site_search?search_term=%D0%9C%D1%96%D0%BA%D1%80%D0%BE+%D0%BF%D0%BE%D0%BD%D0%B8%D0%B6%D1%83%D1%8E%D1%87%D0%B8%D0%B9+DC-DC+%D0%B7+4.7-23%D0%92+%D0%BD%D0%B0+1-17%D0%92%2C+2%D0%90
https://www.rcscomponents.kiev.ua/product/s-diy-0302-dc-dc-4-5-35v-na-1-25-30v-3a-reguliruemyj-modul-zel-nyj_53671.html
marchelloUA 
Поважний учасник


З нами з: 13.04.11
Востаннє: 21.08.17
Повідомлень: 152

2017-05-23 10:01  
В коридор це варіант. Тільки треба щоб було з кріпленням на стіну. Бо в щитку нема місця, на підлозі не варіант (діти полізуть), на вішалці просто поставити небезпечно (ще впаде на голову). Так що поки що дивлюся на такий варіант http://elektro.in.ua/home-catalog/istochniki-besperebojnogo-pitanija/ups-500l.html Просто до нього менший акум піде.
marchelloUA 
Поважний учасник


З нами з: 13.04.11
Востаннє: 21.08.17
Повідомлень: 152

2017-05-23 13:49  
Цитата:

дц-дц степпер

На жаль, це для мене китайська грамота. З електроніки я спромігся колись світлодіод через резистор причепити в дверний дзвінок, працює вже років 15 мабуть. І то тому, що знайомий електронщик дуже детально все пояснив як для тупого. Не мій напрямок... (
lex 
Відео Гуртом - підтримка та поширення
Відео Гуртом - підтримка та поширення


З нами з: 25.12.07
Востаннє: 21.08.17
Повідомлень: 577

2017-05-24 08:02  
я своє добро в комору запхав.
колись стояло в хаті. але шуму забагато було
marchelloUA 
Поважний учасник


З нами з: 13.04.11
Востаннє: 21.08.17
Повідомлень: 152

2017-05-24 13:15  
Добре як є комора, в мене в стандартній хрущовці такого нема. Зробив собі під стандартним щитком ще один щиток і там живе всяке-різне, шкода що наперед не подумав про більший за розміром щиток. Тепер мушу поки що підвішувати решту на стіні.
marchelloUA 
Поважний учасник


З нами з: 13.04.11
Востаннє: 21.08.17
Повідомлень: 152

2017-05-31 21:46  
Затягнув я з тим резервним живленням... Ото вийшов з під'їзду, прочитав оголошення - завтра не буде світла з 9 ранку до 4 дня. І роби що хочеш. Отже працюватиму вночі...
marchelloUA 
Поважний учасник


З нами з: 13.04.11
Востаннє: 21.08.17
Повідомлень: 152

2017-06-01 22:49  
Плюнув на величність суми, поїхав і купив таки LogicPower LPY-W-PSW-1000VA і до нього акумулятор 100Ah. Шумить правда, поки не дозарядить акумулятор до кінця (включається вентилятор автоматично). Потім тиша. В щиток на світчі, etc віддав звичайний старенький комп'ютерний упс powercom з новим акумулятором.

Мій дротовий провайдер від рук відбився, коли світла нема, то і інтернету нема. Сидів в той час на інтертелекомі. Виставив заявку дротовому провайдеру, щоб вставили акумулятор в свій світч на коридорі, нема чого їм розслаблятися. Далі буде видно.
marchelloUA 
Поважний учасник


З нами з: 13.04.11
Востаннє: 21.08.17
Повідомлень: 152

2017-08-06 20:06  
Ну що ж, пройшло 4 місяці бездоганної роботи і зараз щось мабуть змінилося в основного провайдера, так що потрібні зміни в налаштування. Вже другий день сиджу на резервному провайдері, хоча основний провайдер працює ок.

Який досі скрипт:

Цитата:

# jan/02/1970 00:26:48 by RouterOS 6.6
# software id = EI2D-D754
#
/interface ethernet
set [ find default-name=ether1 ] comment=WAN name=ether1_PPPoE
set [ find default-name=ether2 ] name=ether2_Zyxel
set [ find default-name=ether3 ] name=ether3_WAN3
set [ find default-name=ether4 ] comment=LAN name=ether4_masterLAN
set [ find default-name=ether5 ] master-port=ether4_masterLAN
/interface pppoe-client
add disabled=no interface=ether1_PPPoE name=pppoe-out1 password=secret1 use-peer-dns=yes user=user1
/ip neighbor discovery
set ether1_PPPoE comment=WAN
set ether4_masterLAN comment=LAN
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m mac-cookie-timeout=3d
/ip pool
add name=dhcp_pool1 ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=ether4_masterLAN name=dhcp1
/port
set 0 name=serial0
/ip address
add address=192.168.88.1/24 interface=ether4_masterLAN network=192.168.88.0
/ip dhcp-client
add default-route-distance=2 dhcp-options=hostname,clientid disabled=no interface=ether2_Zyxel
/ip dhcp-server network
add address=192.168.88.0/24 dns-server=192.168.88.1 gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes servers=192.168.1.1,8.8.8.8
/ip firewall filter
add chain=input comment=Allow_ping protocol=icmp
add chain=forward protocol=icmp
add chain=input comment=Accept_established_connections connection-state=established
add chain=forward connection-state=established
add chain=input comment=Accept_related_connections connection-state=related
add chain=forward connection-state=related
add action=drop chain=input comment=Drop_invalid_connections connection-state=invalid
add action=drop chain=forward connection-state=invalid
add chain=input comment=Allow_UDP protocol=udp
add chain=forward protocol=udp
add chain=forward comment=Acces_to_Internet_from_local_network src-address=192.168.88.0/24
add chain=input comment=Access_to_Mikrotik_only_from_our_local_network src-address=192.168.88.0/24
add action=drop chain=input comment=All_other_drop
add action=drop chain=forward
/ip firewall mangle
add action=change-mss chain=forward in-interface=ether2_Zyxel new-mss=1440 protocol=tcp tcp-flags=syn tcp-mss=1441-65535
add action=change-mss chain=forward new-mss=1452 out-interface=ether2_Zyxel protocol=tcp tcp-flags=syn tcp-mss=1453-65535
/ip firewall nat
add action=masquerade chain=srcnat out-interface=pppoe-out1
add action=masquerade chain=srcnat out-interface=ether2_Zyxel
/ip firewall service-port
set tftp disabled=yes
set irc disabled=yes
set h323 disabled=yes
set sip disabled=yes
set pptp disabled=yes
/ip route
add check-gateway=ping distance=1 gateway=10.10.10.1
/ip service
set telnet disabled=yes
set ssh address=192.168.88.0/24
set api disabled=yes
set api-ssl disabled=yes
В чому проблема: не спрацьовує перевірка add check-gateway=ping distance=1 gateway=10.10.10.1
Тобто після увімкнення Мікротіка працює основний провайдер добре, але тільки протягом декількох секунд, далі переключається на запасного провайдера.

Пробував замість ping використовувати arp, не допомогло. Змінив вказану стрічку на таку: add distance=1 gateway=10.10.10.1
Тобто зараз просто працюю через основного провайдера і не виконую перевірку на доступність. Так як знаю де в інтерфейсі активовувати (IP -> Routes), то в разі чого буду перемикати вручну (поки).

Хотілося би виконувати пінг 8.8.8.8 через основного провайдера і на основі результату перемикати на резервного провайдера і потім назад, якщо знову доступно. Задав питання на forum.mikrotik.com, однак там діє пре-модерація і мій допис ще не перевірено.

Якщо хтось тут має ідеї, поділіться плз.
marchelloUA 
Поважний учасник


З нами з: 13.04.11
Востаннє: 21.08.17
Повідомлень: 152

2017-08-07 18:58  
Ось так налаштував, наче працює. Тестував шляхом фізичного вимкнення ethernet конектора і увімкнення знов.

Цитата:

# software id = EI2D-D754
#
/interface ethernet
set [ find default-name=ether1 ] comment=WAN name=ether1_PPPoE
set [ find default-name=ether2 ] name=ether2_Zyxel
set [ find default-name=ether3 ] name=ether3_WAN3
set [ find default-name=ether4 ] comment=LAN name=ether4_masterLAN
set [ find default-name=ether5 ] master-port=ether4_masterLAN
/interface pppoe-client
add disabled=no interface=ether1_PPPoE name=pppoe-out1 password=mypassword1 use-peer-dns=yes user=myusername1
/ip neighbor discovery
set ether1_PPPoE comment=WAN
set ether4_masterLAN comment=LAN
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m mac-cookie-timeout=3d
/ip pool
add name=dhcp_pool1 ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=ether4_masterLAN name=dhcp1
/port
set 0 name=serial0
/ip address
add address=192.168.88.1/24 interface=ether4_masterLAN network=192.168.88.0
/ip dhcp-client
add default-route-distance=2 dhcp-options=hostname,clientid disabled=no interface=ether2_Zyxel
/ip dhcp-server network
add address=192.168.88.0/24 dns-server=192.168.88.1 gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes servers=192.168.1.1,8.8.8.8
/ip firewall filter
add chain=input comment=Allow_ping protocol=icmp
add chain=forward protocol=icmp
add chain=input comment=Accept_established_connections connection-state=established
add chain=forward connection-state=established
add chain=input comment=Accept_related_connections connection-state=related
add chain=forward connection-state=related
add action=drop chain=input comment=Drop_invalid_connections connection-state=invalid
add action=drop chain=forward connection-state=invalid
add chain=input comment=Allow_UDP protocol=udp
add chain=forward protocol=udp
add chain=forward comment=Acces_to_Internet_from_local_network src-address=192.168.88.0/24
add chain=input comment=Access_to_Mikrotik_only_from_our_local_network src-address=192.168.88.0/24
add action=drop chain=input comment=All_other_drop
add action=drop chain=forward
/ip firewall mangle
add action=change-mss chain=forward in-interface=ether2_Zyxel new-mss=1440 protocol=tcp tcp-flags=syn tcp-mss=1441-65535
add action=change-mss chain=forward new-mss=1452 out-interface=ether2_Zyxel protocol=tcp tcp-flags=syn tcp-mss=1453-65535
/ip firewall nat
add action=masquerade chain=srcnat out-interface=pppoe-out1
add action=masquerade chain=srcnat out-interface=ether2_Zyxel
/ip firewall service-port
set tftp disabled=yes
set irc disabled=yes
set h323 disabled=yes
set sip disabled=yes
set pptp disabled=yes
/ip route
add check-gateway=ping distance=1 gateway=8.8.8.8 routing-mark=myisp1
add distance=1 gateway=10.10.10.1
add distance=1 dst-address=8.8.8.8/32 gateway=10.10.10.1 scope=10
/ip service
set telnet disabled=yes
set ssh address=192.168.88.0/24
set api disabled=yes
set api-ssl disabled=yes
Додано через 1 годину 18 хвилин 11 секунд:

і ще пару правок:
Цитата:

/ip route
add check-gateway=ping distance=1 gateway=8.8.4.4 routing-mark=astra
add distance=1 gateway=10.10.10.1
add distance=1 dst-address=8.8.4.4/32 gateway=10.10.10.1 scope=10
Ваш часовий пояс: GMT + 2 Години

Нова тема   Відповісти